Testnet block storm may cause irregular block times
Incident Report for Hiro Systems
Resolved
This incident has been resolved.
Posted Apr 17, 2024 - 18:09 CDT
Monitoring
The testnet is currently recovering from a block storm, and as such, may have unusually spaced block times.
Posted Apr 17, 2024 - 15:54 CDT
Investigating
The testnet is currently recovering from a block storm, and as such, may have unusually spaced block times.
Posted Apr 17, 2024 - 12:50 CDT
This incident affected: Services for Testnet (Stacks Blockchain API, Subnets API, Subdomain Registrar).