Scheduled Maintenance for Testnet begins at 11:00am EDT
Incident Report for Hiro Systems
Resolved
This incident has been resolved.
Posted Apr 12, 2024 - 16:57 CDT
Investigating
Maintenance is scheduled to begin on Testnet at 11:00am EDT. During this time, the Hiro Explorer, wallets, and any services using the API endpoints on the Testnet may be impacted.
Posted Apr 12, 2024 - 09:51 CDT
This incident affected: Sites (explorer.hiro.so) and Services for Testnet (Stacks Blockchain API, Subnets API, Subdomain Registrar).