An ongoing Bitcoin Testnet blockstorm and constant reorgs are causing irregular block times
Incident Report for Hiro Systems
Resolved
This incident has been resolved.
Posted Apr 20, 2024 - 07:22 CDT
Monitoring
We are monitoring the situation.
Posted Apr 19, 2024 - 23:49 CDT
This incident affected: Services for Testnet (Stacks Blockchain API, Subnets API, Subdomain Registrar).