Scheduled Testnet Upgrade - expect brief downtime
Incident Report for Hiro Systems
Resolved
Testnet has been successfully updated to the latest Nakamoto 2.5 RC
Posted Apr 13, 2024 - 14:57 CDT
Identified
Testnet upgrade in progress. During this time, the Hiro Explorer, wallets, and any services using the API endpoints on Testnet may be impacted.
Posted Apr 13, 2024 - 14:04 CDT
This incident affected: Services for Mainnet (Stacks Blockchain API) and Sites (explorer.hiro.so).