Stacks Testnet Block Production Issue
Incident Report for Hiro Systems
Resolved
This incident has been resolved.
Posted Nov 24, 2024 - 10:26 CST
Identified
The Stacks Testnet is experiencing issues with block production. Efforts to restore functionality are ongoing, with progress being monitored closely.
Posted Nov 24, 2024 - 01:58 CST
This incident affected: Services for Testnet (Stacks Blockchain API).