Testnet Outage: Team is investigating the current stall on Testnet

Incident Report for Hiro Systems

Resolved

This incident has been resolved.
Posted Sep 12, 2024 - 22:57 EDT

Investigating

Testnet Outage: Team is investigating the current stall on Testnet
Posted Sep 12, 2024 - 12:30 EDT
This incident affected: Sites (explorer.hiro.so) and Services for Testnet (Stacks Blockchain API).