Degraded Testnet API Performance
Incident Report for Hiro Systems
Postmortem

Multiple pool nodes fell behind due to a configuration update issue. The issue was resolved and relevant documentation updated.

Posted Apr 01, 2024 - 17:23 CDT

Resolved
This incident has been resolved.
Posted Mar 20, 2024 - 15:54 CDT
Investigating
We're experiencing degraded performance in the Hiro Testnet API and are currently looking into the issue.
Posted Mar 20, 2024 - 06:32 CDT
This incident affected: Services for Testnet (Stacks Blockchain API).