Degraded Mainnet API Performance
Incident Report for Hiro Systems
Postmortem

Some nodes fell behind for a brief period. They caught up on their own. No action taken.

Posted Feb 25, 2024 - 21:58 CST

Resolved
This incident has been resolved.
Posted Feb 21, 2024 - 01:27 CST
Investigating
We're experiencing degraded performance in the Hiro Mainnet API and are currently looking into the issue.
Posted Feb 21, 2024 - 01:12 CST
This incident affected: Services for Mainnet (Stacks Blockchain API), Sites (explorer.hiro.so), and Apps (Leather Desktop Wallet, Leather Web Wallet).