A fix has been implemented and we are monitoring the results.
Posted Jun 03, 2026 - 07:22 EDT
Investigating
We are investigating an issue with the Testnet Stacks Blockchain Seed Node that began at Jun 3, 2026, 6:28 AM ET. Data retrieved from this API’s endpoints may be several blocks behind. The Stacks Explorer, wallets, and any services using the Testnet API may be impacted. We will share more details as additional information becomes available.
Posted Jun 03, 2026 - 06:58 EDT
This incident affected: Services for Testnet (Stacks Blockchain API).