Degraded Testnet API Performance
Incident Report for Hiro Systems
Postmortem

Multiple nodes fell behind for a brief period while block production was slow. They caught up on their own. No action taken.

Posted Apr 01, 2024 - 15:57 CDT

Resolved
This incident has been resolved.
Posted Mar 15, 2024 - 01:13 CDT
Investigating
We're experiencing degraded performance in the Hiro Testnet API and are currently looking into the issue.
Posted Mar 15, 2024 - 01:11 CDT
This incident affected: Services for Testnet (Stacks Blockchain API).