Testnet progress paused

Incident Report for Hiro Systems

Resolved

This incident has been resolved.
Posted Dec 17, 2024 - 23:43 EST

Investigating

We are currently investigating this issue.
Posted Dec 17, 2024 - 20:38 EST
This incident affected: Services for Testnet (Stacks Blockchain API).