We are continuing to monitor for any further issues.
Posted Nov 18, 2025 - 10:11 EST
Update
Cloudflare's outage is still impacting Hiro services. We will continue to monitor the situation to ensure our services are restored as soon as Cloudflare's incident is resolved.
We are investigating an issue with the Platform Frontend service that began at Nov 18, 2025, 8:00 AM ET. Additional information will be shared once it becomes available.
Posted Nov 18, 2025 - 08:00 EST
This incident affected: Platform (platform.hiro.so).