Degraded Ordinals API Performance

Incident Report for Hiro Systems

Resolved

This incident has been resolved.
Posted Nov 19, 2023 - 19:49 EST

Investigating

We're experiencing degraded performance in the Hiro mainnet Ordinals API and are currently looking into the issue.
Posted Nov 19, 2023 - 17:40 EST
This incident affected: Services for Mainnet (Ordinals API).