Testnet Stacks Blockchain API Outage

Incident Report for Hiro Systems

Resolved

This incident has been resolved.
Posted Jun 02, 2025 - 04:25 EDT

Investigating

We are investigating an issue with the Testnet API service that began at Jun 2, 2025, 4:20 AM ET.\nData retrieved from this API’s endpoints may be several blocks behind.\nAny services using the Testnet API may be impacted.\nWe will share more details as additional information becomes available.
Posted Jun 02, 2025 - 04:20 EDT
This incident affected: Services for Testnet (Stacks Blockchain API) and explorer.hiro.so.