Slow Block Progression in Testnet

Incident Report for Hiro Systems

Resolved

We've temporarily increased the `satoshis_per_byte` value set in our testnet miner to alleviate some of the block progression pains while we continue investigating for a root cause in the logic, which has resulted in an improved block progression.

We'll continue monitoring the block production and adjust as needed.
Posted Mar 02, 2023 - 16:10 EST

Update

We are continuing to monitor for any further issues.
Posted Mar 02, 2023 - 13:52 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 02, 2023 - 13:52 EST

Investigating

We are investigating an issue in Hiro's testnet miner which is affecting its ability to mine blocks when `satoshis_per_byte` is configured below a certain amount.
This is affecting the block rate in the Stacks testnet.

Blocks *may still be mined*, but possibly at a slower rate than expected. We're actively debugging the issue right now and we'll post any updates here.
Posted Mar 02, 2023 - 13:01 EST
This incident affected: Services for Testnet (Stacks Blockchain API) and explorer.hiro.so.