API Performance Degraded
Incident Report for Hiro Systems
Postmortem

The API was running out of memory due to a steady increase in load which caused parts of the system to fail. Service was restored after adjusting resources.

Posted Apr 01, 2024 - 17:35 CDT

Resolved
Hiro’s Stack API was running out of memory due to a steady increase in load and causing parts of the system to fail. Service has now been restored after adjusting resources.
Posted Mar 24, 2024 - 04:48 CDT
Investigating
We're experiencing performance degradation in Hiro's Stacks Blockchain API and are currently looking into the issue. During this time, Hiro's Explorer, wallets, and any services using the API may be impacted.
Posted Mar 24, 2024 - 03:54 CDT
This incident affected: Services for Mainnet (Stacks Blockchain API), Sites (explorer.hiro.so), and Apps (Leather Desktop Wallet, Leather Web Wallet).