Block pause on Mainnet

Incident Report for Hiro Systems

Resolved

This incident has been resolved.
Posted Jan 13, 2025 - 08:28 EST

Update

We are currently investigating this issue.
Posted Jan 13, 2025 - 08:07 EST

Investigating

We are currently investigating this issue.
Posted Jan 13, 2025 - 08:05 EST
This incident affected: Services for Mainnet (Stacks Blockchain API) and Sites (explorer.hiro.so).