Intermittent Hiro node lag on Mainnet
Incident Report for Hiro Systems
Resolved
This has been resolved. All stacks nodes are now updated to the https://github.com/stacks-network/stacks-core/releases/tag/2.5.0.0.7 release with the fix.
Posted Sep 19, 2024 - 00:12 CDT
Update
Our Stacks nodes are intermittently lagging behind the chain tip, the team is working through a patch to fix this.
More details to follow.

This is unrelated to Nakamoto and should be resolved today.
Posted Sep 18, 2024 - 12:20 CDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 18, 2024 - 11:03 CDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 18, 2024 - 11:03 CDT
Identified
Team has identified a fix and testing it
Posted Sep 18, 2024 - 10:54 CDT
This incident affected: Services for Mainnet (Stacks Blockchain API) and Sites (explorer.hiro.so).