Degraded API Performance
Incident Report for Hiro Systems
Postmortem

Impact

All clients that relied on the /v2/accounts endpoint for the mainnet and testnet Hiro API were impacted. This includes the Explorer, Stacks desktop and web wallets, the stacks CLI, and others. Requests on all other endpoints to the APIs were still being served and were unaffected.

Root cause

A change to our external network security rules ended up blocking valid traffic. Reverting the change restored functionality to the /v2/accounts endpoint.

Action Items

  • Reassess and expand upon the URLs being monitored internally to better catch unintended network changes
Posted Jun 06, 2023 - 15:50 CDT

Resolved
This incident has been resolved.
Posted Jun 06, 2023 - 08:23 CDT
Investigating
We're experiencing degraded performance in the Hiro mainnet API and are currently looking into the issue.
Posted Jun 06, 2023 - 05:37 CDT
This incident affected: Services for Mainnet (Stacks Blockchain API), Sites (explorer.hiro.so), and Apps (Leather Desktop Wallet, Leather Web Wallet).