Platform Frontend Outage

Incident Report for Hiro Systems

Resolved

This incident has been resolved.
Posted May 24, 2025 - 11:22 EDT

Investigating

We are investigating an issue with the Platform Frontend service that began at May 24, 2025, 11:21 AM ET.
Posted May 24, 2025 - 11:21 EDT
This incident affected: Platform (platform.hiro.so).