Elevated Response Times on Hiro Platform

Incident Report for Hiro Systems

Resolved

This incident has been resolved.
Posted May 17, 2025 - 10:21 EDT

Investigating

The Hiro Platform is currently experiencing unusually long response times. Our team is actively working on a fix. We’ll share updates as we make progress—thank you for your patience.
Posted May 17, 2025 - 06:04 EDT
This incident affected: Platform (Backend, platform.hiro.so).