Hiro services outage
Incident Report for Hiro Systems
Postmortem

Impact

Multiple Hiro services we impacted, including the Explorer, APIs, the Platform, and Platform VSCode environments. All clients that relied on the mainnet and testnet Hiro APIs were impacted, including the Explorer, Stacks desktop and web wallets, the stacks CLI, and others. Requests on all endpoints to these affected services were not being served.

Root cause

The rollout of a new internal service for the Platform VSCode environments led to our gateway proxies to suddenly become inundated with additional workloads, resulting in repeated out-of-memory errors (OOMs) for each instance of the gateway proxy. Once memory was increased for the gateway proxies, service was immediately restored to the Explorer, APIs, Platform, and any clients relying on the APIs.

Service to the Platform VSCode environments was slowly restored afterwards, as the new internal service completed rolling out.

Action Items

  • We’re assessing how we can more accurately mirror our production traffic for the Platform VSCode deployments in a separate staging environment to better prepare for large infrastructure changes.
Posted Jun 06, 2023 - 16:00 CDT

Resolved
This incident has been resolved.
Posted Jun 06, 2023 - 11:25 CDT
Update
We are continuing to monitor for any further issues.
Posted Jun 06, 2023 - 11:18 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 06, 2023 - 10:35 CDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 06, 2023 - 10:31 CDT
This incident affected: Services for Mainnet (Stacks Blockchain API, Ordinals API), Sites (explorer.hiro.so, hiro.so), Apps (Leather Desktop Wallet, Leather Web Wallet), and Services for Testnet (Stacks Blockchain API).