Platform Frontend Outage

Incident Report for Hiro Systems

Resolved

This incident has been resolved.
Posted Jun 20, 2026 - 08:52 EDT

Investigating

We are investigating an issue with the Platform Frontend service that began at Jun 20, 2026, 12:02 AM ET.
Additional information will be shared once it becomes available.
Posted Jun 20, 2026 - 00:02 EDT
This incident affected: Platform (platform.hiro.so).