Degraded API Performance
Incident Report for Hiro Systems
Resolved
This incident has been resolved. Our services are experiencing elevated levels of traffic. We'll keep a close eye on it as we consider potentially scaling up to handle the increased load.
Posted Apr 17, 2023 - 21:37 CDT
Investigating
We're experiencing degraded performance in the Hiro mainnet API and are currently looking into the issue.
Posted Apr 17, 2023 - 21:36 CDT
This incident affected: Services for Mainnet (Stacks Blockchain API), Sites (explorer.hiro.so), and Apps (Leather Desktop Wallet, Leather Web Wallet).