Degraded API Performance

Incident Report for Hiro Systems

Resolved

This incident has been resolved.
Posted Nov 08, 2023 - 01:24 EST

Investigating

We're experiencing degraded performance in the Hiro testnet API and are currently looking into the issue.
Posted Nov 07, 2023 - 13:07 EST
This incident affected: Services for Testnet (Stacks Blockchain API).