Degraded Ordinals API Performance

Incident Report for Hiro Systems

Resolved

This incident has been resolved.
Posted Aug 31, 2023 - 10:21 EDT

Investigating

We're experiencing degraded performance in the Hiro mainnet Ordinals API and are currently looking into the issue.
Posted Aug 31, 2023 - 09:41 EDT
This incident affected: Services for Mainnet (Ordinals API).