Testnet Stacks Blockchain API Outage

Incident Report for Hiro Systems

Resolved

This incident has been resolved.
Posted May 26, 2025 - 04:20 EDT

Investigating

We are investigating an issue with the Testnet Token Metadata API service that began at May 26, 2025, 4:15 AM ET.
Posted May 26, 2025 - 04:15 EDT
This incident affected: Services for Testnet (Stacks Blockchain API) and explorer.hiro.so.