Testnet API Outage

Incident Report for Hiro Systems

Resolved

This incident has been resolved.
Posted Feb 26, 2025 - 05:26 EST

Investigating

We're experiencing degraded performance in the Hiro Testnet API and are currently looking into the issue.
Posted Feb 26, 2025 - 05:21 EST
This incident affected: Services for Testnet (Stacks Blockchain API).