Degraded Performance
Incident Report for Hiro Systems
Resolved
Our APIs are back online with version v5 now
API Docker image: hirosystems/stacks-blockchain-api:pr-1380
Stacks Blockchain Docker image: blockstack/stacks-blockchain:2.05.0.5.0-rc1


For those running API v6
API Docker image: hirosystems/stacks-blockchain-api:6.1.1
Stacks Blockchain Docker image: blockstack/stacks-blockchain:2.05.0.5.0-rc1

For those running API v4
API Docker image: hirosystems/stacks-blockchain-api:pr-1381
Stacks Blockchain Docker image: blockstack/stacks-blockchain:2.05.0.5.0-rc1
Posted Oct 24, 2022 - 09:08 CDT
Update
Our APIs are back online with version v6.1.1
API Docker image: hirosystems/stacks-blockchain-api:6.1.1
Stacks Blockchain Docker image: blockstack/stacks-blockchain:2.05.0.5.0-rc1


For those running API v5
API Docker image: hirosystems/stacks-blockchain-api:pr-1380 (wait until PR finishes building first)
Stacks Blockchain Docker image: blockstack/stacks-blockchain:2.05.0.5.0-rc1

For those running API v4
API Docker image: hirosystems/stacks-blockchain-api:pr-1381
Stacks Blockchain Docker image: blockstack/stacks-blockchain:2.05.0.5.0-rc1
Posted Oct 24, 2022 - 09:07 CDT
Update
Our APIs are back online with version v6.1.1
v6.1.1, v5.0.2-hotfix, v4.1.3-hotifx are now available with this fix.

Please use these latest versions for API with the latest 2.05.0.5.0-rc1 stacks-node
Posted Oct 24, 2022 - 09:07 CDT
Update
We updated our API to better handle the poison microblock tx type https://github.com/hirosystems/stacks-blockchain-api/issues/1378
We are now backporting this fix to v4x, v5x and v6x
Posted Oct 24, 2022 - 08:48 CDT
Update
We upgraded our nodes to 2.05.0.5.0-rc1 and syncing our APIs to catch up to the chaintip
Posted Oct 24, 2022 - 08:30 CDT
Identified
The issue has been identified; a hotfix is being worked on and will be deployed as soon as it's ready. Until then, the API and Explorer may not show the latest blocks produced in the Stacks mainnet and testnet networks.
Posted Oct 24, 2022 - 07:43 CDT
Investigating
We're experiencing degraded performance in the Hiro mainnet Stacks Node and are currently looking into the issue.
Posted Oct 24, 2022 - 04:32 CDT
This incident affected: Services for Mainnet (Stacks Blockchain API), Sites (explorer.hiro.so), and Apps (Leather Desktop Wallet, Leather Web Wallet).