Testnet progress paused
Incident Report for Hiro Systems
Postmortem

Root Cause:
The testnet's challenges originated from unresolved technical debt dating back to the Nakamoto consensus launch in 2024. These issues were compounded by configuration mismatches between the Bitcoin regtest and the Stacks testnet, particularly during the epoch transition. Additionally, decentralized ownership and holiday season delays led to gaps in communication and coordination across the ecosystem.

Recovery Steps:

  1. Initial Reset: Devs attempted a reset to resolve the issues, rolling the testnet back to a block before the problematic epoch transition. While this initially seemed promising, the reset failed to restore stability.
  2. Further Investigation: Developers identified several potential configuration changes to address the root cause and improve stability.
  3. Testnet Restoration: By Jan 4, 2025, the testnet was brought back online in a reduced state, allowing developers to continue optimization while gradually restoring full functionality.

Next Steps:

  • Resolve underlying technical debt to ensure the testnet operates in a stable, reliable state.
  • Implement identified configuration changes to enhance long-term stability.
  • Improve communication protocols across ecosystem contributors to provide timely updates during future incidents
Posted Feb 04, 2025 - 08:52 EST

Resolved
Testnet is back to running normally
Posted Jan 06, 2025 - 07:26 EST
Update
Testnet is operational, but being run in a reduced state while devs continue to work through a number of optimizations for it.
Posted Jan 03, 2025 - 22:50 EST
Update
Developers are continuing to work on fully restoring the testnet and have identified some configuration changes that will further increase it's stability. A further update later tonight or tomorrow morning.
Posted Jan 02, 2025 - 18:42 EST
Update
A reset of the Primary Testnet is underway and expected to be completed in the next few hours. Further updates will be provided after it is completed.
Posted Jan 02, 2025 - 12:14 EST
Update
Core Developers are continuing to work on resetting the Stacks testnet, and expect it to be completed by EOD on Jan 2nd. Until then, testnet functionality may be limited.
Posted Jan 01, 2025 - 10:39 EST
Identified
The Stacks testnet is in the process of being reset and migrated back to the latest epoch (3.1), and will likely be completed by Dec 30th. Until then, testnet functionality may be limited.
Posted Dec 29, 2024 - 01:13 EST
Investigating
We are currently investigating this issue.
Posted Dec 25, 2024 - 12:07 EST
This incident affected: Services for Testnet (Stacks Blockchain API, Token Metadata API).