Testnet Stacks Signer Outage

Incident Report for Hiro Systems

Resolved

This incident has been resolved.
Posted Jun 03, 2026 - 09:00 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 03, 2026 - 07:22 EDT

Investigating

We are investigating an issue with the Testnet Stacks Blockchain Signer that began at Jun 3, 2026, 6:28 AM ET.
We will share more details as additional information becomes available.
Posted Jun 03, 2026 - 06:29 EDT
This incident affected: Services for Testnet (Stacks Blockchain API).