Degraded API Performance

Incident Report for Hiro Systems

Resolved

This incident has been resolved.
Posted Sep 14, 2023 - 16:54 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 14, 2023 - 15:39 EDT

Investigating

We're experiencing degraded performance in the Hiro mainnet API and are currently looking into the issue.
Posted Sep 14, 2023 - 15:21 EDT
This incident affected: Services for Mainnet (Stacks Blockchain API) and explorer.hiro.so.