Mainnet API Outage
Incident Report for Hiro Systems
Postmortem

The API was running out of memory due to a steady increase in load which caused parts of the system to fail. Service was restored after adjusting resources.

Posted Apr 01, 2024 - 17:39 CDT

Resolved
Hiro’s Stack API was running out of memory due to a steady increase in load and causing parts of the system to fail. Service has now been restored after adjusting resources.
Posted Mar 24, 2024 - 04:41 CDT
Investigating
We're experiencing degraded performance in the Hiro Mainnet API and are currently looking into the issue.
Posted Mar 24, 2024 - 04:31 CDT
This incident affected: Services for Mainnet (Stacks Blockchain API), Sites (explorer.hiro.so), and Apps (Leather Desktop Wallet, Leather Web Wallet).