Testnet temporarily paused
Incident Report for Hiro Systems
Resolved
This incident has been resolved.
Posted Nov 29, 2024 - 12:21 CST
Update
The issue has been identified and a fix is being implemented.
Posted Nov 29, 2024 - 11:53 CST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 29, 2024 - 11:45 CST
Investigating
We are currently investigating this issue.
Posted Nov 29, 2024 - 10:31 CST
This incident affected: Services for Testnet (Stacks Blockchain API).