We're are aware of a stall on the Mainnet Stacks Core and the core team is currently looking into the issue.

Incident Report for Hiro Systems

Resolved

The incident has been resolved, and block production has resumed. While the network stabilizes, there may be some intermittent hiccups.
Posted Jul 08, 2025 - 18:23 EDT

Update

The core team is working with the Signers to upgrade and move the chain along. Meanwhile, if you run any Stacks node or Signer: Upgrade your stacks-core to 3.1.0.0.13 when you do your restore
- Check your node's v2/info: curl -s http://cet.stacksnodes.org:20443/v2/info | jq .burn_block_height
- If the burn block height returned is at or near the current bitcoin tip (check mempool.space), your signer is running okay.
- If not, you will need to restore your stacks-node from a snapshot
- If you have one, restore your stacks-node from your own snapshot (as long as it is older than the stall -- 1:30PM Eastern). If not, use the Hiro archive: https://archive.hiro.so/mainnet/stacks-blockchain/mainnet-stacks-blockchain-3.1.0.0.11-20250707.tar.gz
- Upgrade your stacks-core to 3.1.0.0.13 when you do your restore
Posted Jul 08, 2025 - 17:17 EDT

Update

If you run any Stacks node or Signer: Upgrade your stacks-core to 3.1.0.0.13 when you do your restore
- Check your node's v2/info: curl -s http://cet.stacksnodes.org:20443/v2/info | jq .burn_block_height
- If the burn block height returned is at or near the current bitcoin tip (check mempool.space), your signer is running okay.
- If not, you will need to restore your stacks-node from a snapshot
- If you have one, restore your stacks-node from your own snapshot (as long as it is older than the stall -- 1:30PM Eastern). If not, use the Hiro archive: https://archive.hiro.so/mainnet/stacks-blockchain/mainnet-stacks-blockchain-3.1.0.0.11-20250707.tar.gz
- Upgrade your stacks-core to 3.1.0.0.13 when you do your restore
Posted Jul 08, 2025 - 14:59 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 08, 2025 - 14:24 EDT

Investigating

We are currently investigating this issue.
Posted Jul 08, 2025 - 13:53 EDT
This incident affected: Services for Mainnet (Stacks Blockchain API, Ordinals API, Runes API, Token Metadata API, Chainhook, Signer Metrics API).