Platform Frontend Outage

Incident Report for Hiro Systems

Resolved

This incident has been resolved.
Posted Jun 13, 2025 - 08:36 EDT

Investigating

We're experiencing a major outage in the Hiro Platform Frontend that began at Jun 13, 2025, 8:33 AM ET and are currently looking into the issue.
Posted Jun 13, 2025 - 08:33 EDT
This incident affected: Platform (platform.hiro.so).