API Outage

Incident Report for Hiro Systems

Resolved

This incident has been resolved.
Posted Jul 07, 2023 - 09:31 EDT

Investigating

We're experiencing a major outage in the Hiro testnet API and are currently looking into the issue.
Posted Jul 07, 2023 - 03:32 EDT
This incident affected: Services for Testnet (Stacks Blockchain API).