Mainnet API Block Progression Stalled

Incident Report for Hiro Systems

Resolved

This incident has been resolved.
Posted Dec 26, 2025 - 11:32 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 25, 2025 - 13:31 EST

Investigating

We're investigating a stall in block progression for the Mainnet Stacks Blockchain API.
Posted Dec 25, 2025 - 12:44 EST
This incident affected: Services for Mainnet (Stacks Blockchain API) and explorer.hiro.so.