Inconsistent chain state in API Testnet
Incident Report for Hiro Systems
Resolved
This incident has been resolved.
Posted Jun 23, 2023 - 15:55 CDT
Monitoring
The fix is in place and we are testing to verify.
Posted Jun 22, 2023 - 12:02 CDT
Update
The genesis sync is complete; the fix is in the process of being applied.
Posted Jun 22, 2023 - 10:46 CDT
Update
We are making progress on the genesis sync. Account balances and faucet transactions will remain affected until then.
Posted Jun 21, 2023 - 13:47 CDT
Update
We are re-syncing to resolve the issue, which will take a few days. Account balances and faucet transactions will remain affected until then.
Posted Jun 20, 2023 - 20:21 CDT
Identified
We have discovered root cause for the issue, which is missing data from the genesis block. We are re-syncing now to resolve.
Posted Jun 20, 2023 - 13:48 CDT
Investigating
We are currently investigating an issue where faucet transactions on testnet API are stuck in pending status.
Posted Jun 20, 2023 - 13:39 CDT
This incident affected: Services for Testnet (Stacks Blockchain API).