Hiro node lag on Mainnet
Incident Report for Hiro Systems
Resolved
This incident has been resolved.
Posted Sep 18, 2024 - 10:15 CDT
Update
We are currently investigating the issue. Our team is working and will provide updates as more information becomes available.
Posted Sep 18, 2024 - 08:42 CDT
Identified
We are experiencing an issue with a few Mainnet nodes getting stuck and struggling to progress.
Posted Sep 18, 2024 - 06:35 CDT
This incident affected: Services for Mainnet (Stacks Blockchain API) and Sites (explorer.hiro.so).