Testnet API Outage
Incident Report for Hiro Systems
Resolved
This incident has been resolved.
Posted Jan 16, 2025 - 01:53 EST
Investigating
We're experiencing degraded performance in the Hiro Testnet API and are currently looking into the issue.
Posted Jan 16, 2025 - 01:45 EST
This incident affected: Services for Testnet (Stacks Blockchain API).