Degraded Mainnet API Performance
Incident Report for Hiro Systems
Postmortem

The chain had a period without any new STX blocks. The blocks resumed. No action taken.

Posted Feb 23, 2024 - 12:20 CST

Resolved
This incident has been resolved.
Posted Feb 14, 2024 - 17:43 CST
Investigating
We're experiencing degraded performance in the Hiro Mainnet API and are currently looking into the issue.
Posted Feb 14, 2024 - 17:16 CST
This incident affected: Services for Mainnet (Stacks Blockchain API), Sites (explorer.hiro.so), and Apps (Leather Desktop Wallet, Leather Web Wallet).