Mainnet API Outage

Incident Report for Hiro Systems

Resolved

This incident has been resolved.
Posted Apr 29, 2025 - 22:07 EDT

Investigating

We're experiencing degraded performance in the Hiro Mainnet API and are currently looking into the issue.
Posted Apr 29, 2025 - 22:02 EDT
This incident affected: Services for Mainnet (Stacks Blockchain API) and explorer.hiro.so.