Degraded API Performance
Incident Report for Hiro Systems
Postmortem

Impact

All clients that relied on the Hiro API. This includes the Explorer, Hiro desktop and web wallets, the stacks CLI, and others. Requests were still being served, but performance was degraded to the point where some requests timed out.

Root Cause

Performance was degraded by an influx of traffic causing several slow database queries. It was determined that this traffic was the result of an NFT release.

Action Items

  • The slow queries causing the degraded performance are being worked on in the API and are anticipated to be patched this week.
  • A query timeout was configured in our backend API databases to help keep down the number of slow queries running, and ensure the API stays performant for the majority of users.
Posted Feb 21, 2022 - 10:34 CST

Resolved
API performance was degraded due to an influx of traffic creating several slow database queries.
Posted Feb 19, 2022 - 09:00 CST