Degraded API Performance
Incident Report for Hiro Systems
Postmortem

Impact

All clients that relied on the mainnet Hiro API were impacted. This includes the Explorer, Stacks desktop and web wallets, the stacks CLI, and others. Requests on all endpoints to the mainnet API were still being served, but may have received outdated data.

Root cause

The mainnet Stacks Blockchain API instances serving traffic were experiencing connection issues to the Stacks Blockchain nodes it depended upon. We believe this issue is related, and it’s being investigated right now.

Action Items

  • Updated our alerts to notify us of similar errors sooner
  • Re-prioritized this related API issue to make the service more resilient to infrastructure changes
Posted Apr 26, 2023 - 11:11 CDT

Resolved
This incident has been resolved.
Posted Apr 25, 2023 - 21:18 CDT
Investigating
We're experiencing degraded performance in the Hiro mainnet API and are currently looking into the issue.
Posted Apr 25, 2023 - 19:34 CDT
This incident affected: Services for Mainnet (Stacks Blockchain API), Sites (explorer.hiro.so), and Apps (Leather Desktop Wallet, Leather Web Wallet).