API Outage
Incident Report for Hiro Systems
Postmortem

Impact

All clients that relied on the mainnet Hiro API. This includes the Explorer, Hiro desktop and web wallets, the stacks CLI, and others. Requests on all endpoints to the mainnet API were unable to be served.

Root cause

Cloudflare, our network proxy provider, experienced an outage affecting most downstream client services.
https://blog.cloudflare.com/cloudflare-outage-on-june-21-2022/

Action Items

  • We are investigating reducing our reliance on Cloudflare in the future.
Posted Jun 21, 2022 - 19:12 UTC

Resolved
This incident has been resolved.
Posted Jun 21, 2022 - 07:43 UTC
Update
We are continuing to investigate this issue.
Posted Jun 21, 2022 - 07:42 UTC
Investigating
We're experiencing a major outage in the Hiro mainnet API and are currently looking into the issue.
Posted Jun 21, 2022 - 07:41 UTC
This incident affected: Sites (explorer.stacks.co), Services for Mainnet (Stacks Blockchain API), and Apps (Hiro Desktop Wallet, Hiro Web Wallet).