Mainnet API Outage
Incident Report for Hiro Systems
Resolved
This incident has been resolved.
Posted Feb 18, 2024 - 03:20 CST
Investigating
We're experiencing degraded performance in the Hiro Mainnet API and are currently looking into the issue.
Posted Feb 18, 2024 - 03:15 CST
This incident affected: Services for Mainnet (Stacks Blockchain API), Sites (explorer.hiro.so), and Apps (Leather Desktop Wallet, Leather Web Wallet).