Degraded Mainnet API Performance
Incident Report for Hiro Systems
Postmortem

The API had a brief period of slow response. The issue resolved on its own.

Posted Feb 23, 2024 - 11:51 CST

Resolved
This incident has been resolved.
Posted Feb 10, 2024 - 01:35 CST
Investigating
We're experiencing degraded performance in the Hiro mainnet API and are currently looking into the issue.
Posted Feb 10, 2024 - 01:30 CST
This incident affected: Services for Mainnet (Stacks Blockchain API), Sites (explorer.hiro.so), and Apps (Leather Desktop Wallet, Leather Web Wallet).