Degraded API Performance
Incident Report for Hiro Systems
Resolved
This incident has been resolved.
Posted May 19, 2023 - 02:02 CDT
Investigating
We're experiencing degraded performance in the Hiro mainnet API and are currently looking into the issue.
Posted May 19, 2023 - 01:57 CDT
This incident affected: Services for Mainnet (Stacks Blockchain API), Sites (explorer.hiro.so), and Apps (Leather Desktop Wallet, Leather Web Wallet).