Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 10, 2024 - 15:10 CDT
Scheduled
We will be undergoing scheduled maintenance during this time. There may be a few seconds of services being unavailable if any, but this should this subside quickly.
Posted Jul 10, 2024 - 15:05 CDT
This scheduled maintenance affected: Services for Mainnet (Stacks Blockchain API, Ordinals API, Subdomain Registrar), Sites (explorer.hiro.so), and Services for Testnet (Stacks Blockchain API, Subdomain Registrar).